QwickCards Incident Notice
Incident Report for QwickCards
Update
We are continuing to work on a fix for this issue.
Posted Apr 29, 2024 - 15:17 UTC
Update
Dear QwickCards.com Users,

The QwickCards service has been restored. Unfortunately, during our transition to new HSMs, some institution-specific key cryptograms were not able to be moved. Those customers have been notified and we are actively working with them to be re-boarded.

We are implementing stringent measures to prevent outages in the future while we are still analyzing the root cause of this outage. Once complete, we will communicate our findings as soon as practicable.

We appreciate your business and are thankful for your patience.

Thank you for being a valued user of QwickCards.com.

Best regards,
MagTek, Inc.
Posted Apr 29, 2024 - 15:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2024 - 18:31 UTC
Update
Dear QwickCards.com Users,

Our Engineering and IT teams have successfully migrated QwickCards to another platform with working HSMs. The cryptogram migration process is tedious and time-consuming, and we remain dedicated to accomplishing these tasks as quickly as possible.

QwickCards is still down while we go through this migration.

We appreciate your patience and understanding during this time.

Thank you for being a valued user of QwickCards.com.

Best regards,
MagTek, Inc.
Posted Apr 25, 2024 - 22:49 UTC
Update
Dear QwickCards.com Users,

Our Engineering and IT teams have been working to migrate QwickCards from the failed HSMs to another platform with working HSMs. That necessitated building and configuring a new service that allows the commands sent by QwickCards to translate from the previous HSM platform to the new platform. We are pleased to report that we have validated this new service in both Dev and QA and will begin migrating the cryptograms to the new production HSMs.

This should allow us to fully restore the QwickCards service. The cryptogram migration process is tedious and not without its own challenges, so please bear with us as we work to complete this process.

Thank you for your continued support.

Best regards,
MagTek, Inc.
Posted Apr 23, 2024 - 16:14 UTC
Update
Dear QwickCards.com Users,

Our engineering team continues to make progress on restoring the HSMs. We will continue the process on Sunday. Once again, we will provide an update tomorrow (Sunday).

We sincerely appreciate your patience and understanding during this time, and we apologize for any inconvenience caused by this outage.

Thank you for your continued support.

Best regards,
MagTek, Inc.
Posted Apr 21, 2024 - 01:38 UTC
Update
Dear QwickCards.com Users,

We are currently in the process of re-initializing and reloading keys in the HSMs. However, we regret to inform you that we are experiencing unexpected delays. We will post the next update tomorrow.

We sincerely appreciate your patience and understanding during this time, and we apologize for any inconvenience caused by this outage.

Thank you for your continued support.

Best regards,
MagTek, Inc.
Posted Apr 20, 2024 - 01:29 UTC
Update
Dear QwickCards.com Users,

Our engineering team has restored a Production HSM to normal operation, and they are now in the process of re-initializing and reloading its keys. We are optimistic that full service with QwickCards.com will be restored shortly.

Thank you for your patience and understanding during this time and we apologize for the inconvenience this outage has caused.

Sincerely,
MagTek, Inc.
Posted Apr 19, 2024 - 18:19 UTC
Update
Dear QwickCards.com Users,

Our engineering team has isolated the issue, and we are in the process of re-installing the necessary replacement components to bring the HSMs back online. We are optimistic that full service will be restored.

We will provide periodic updates over the next few hours.

Thank you for your patience and understanding during this time and we apologize for the inconvenience this outage has caused.

Sincerely, MagTek, Inc.
Posted Apr 19, 2024 - 14:10 UTC
Identified
Dear QwickCards.com Users,

This morning, we encountered an issue with our Primary and Secondary Hardware Security Modules (HSMs) at QwickCards.com, resulting in a service disruption. Our engineering team is actively working to restore services using backup HSMs that contain the necessary cryptograms.

Please rest assured that restoring service is our highest priority, and MagTek's executive management is fully briefed on the situation.

We anticipate providing an update later today. We appreciate your patience and understanding during this time.

Thank you for being a valued user of QwickCards.com.

Sincerely,
MagTek, Inc.
Posted Apr 18, 2024 - 18:58 UTC
Investigating
We are currently investigating. RePIN is currently not operational.
Posted Apr 18, 2024 - 13:01 UTC
This incident affects: QwickCards.com.