QwickCards response times are slow

Incident Report for QwickCards

Resolved

Connectivity issues resolved.
Posted Jul 09, 2025 - 20:51 UTC

Investigating

We are currently investigating this issue and will update with additional information.
Posted Jul 09, 2025 - 20:40 UTC
This incident affected: QwickCards.com and QwickCards.com Job Server.