ExpressCard devices unable to connect to QwickCards job server (QwickCards.com is Offline)
Incident Report for QwickCards
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 07, 2019 - 16:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Jan 07, 2019 - 15:08 UTC
Investigating
We are currently investigating this issue.
Posted 7 months ago. Jan 07, 2019 - 14:45 UTC
This incident affected: QwickCards.com Job Server.