QwickCards Partial Outage 27NOV17
Incident Report for QwickCards
Resolved
The issue has been resolved and QwickCards is fully operational.
Posted over 1 year ago. Nov 27, 2017 - 15:50 UTC
Identified
The issue has been identified and technicians are working on resolution.
Posted over 1 year ago. Nov 27, 2017 - 14:41 UTC
Investigating
An inability to select PINs has been reported. We are investigating the issue.
Posted over 1 year ago. Nov 27, 2017 - 14:04 UTC