"Card Authentication Failed" error when attempting login.
Incident Report for QwickCards
Resolved
This incident has been resolved.
Posted Dec 01, 2022 - 20:40 UTC
Investigating
We are currently investigating this issue.
Posted Dec 01, 2022 - 20:12 UTC
This incident affected: QwickCards.com.