QwickCards EMV card perso service partial outage
Incident Report for QwickCards
Resolved
All MagTek internal systems were fully operational. The cause for this partial outage appears to have been due to regional ISP issues. If you continue to experience issues, please contact your ISP to see if they have any ongoing issues.
Posted over 1 year ago. Jan 19, 2018 - 23:42 UTC
Investigating
We have received reports of problems with the QwickCards perso service. We are investigating and will provide updates as details emerge.
Posted over 1 year ago. Jan 19, 2018 - 23:04 UTC