QwickCards user login failure
Incident Report for QwickCards
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 13, 2018 - 13:08 UTC
Update
We are continuing to investigate this issue.
Posted 11 months ago. Aug 13, 2018 - 13:08 UTC
Investigating
We are investigating the cause of the issue.
Posted 11 months ago. Aug 13, 2018 - 12:34 UTC
This incident affected: QwickCards.com.