Login problem 2APR18
Incident Report for QwickCards
Resolved
QwickCards login access has been restored.
Posted about 1 year ago. Apr 02, 2018 - 13:26 UTC
Investigating
An inability to login. Login attempt returns the message "“Server returned an error. Please try again or contact system administrator”.
Posted about 1 year ago. Apr 02, 2018 - 12:57 UTC