Password Reset emails not reaching targets
Incident Report for QwickCards
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 10:55 UTC
Investigating
We are currently investigating this issue.
Posted Apr 01, 2021 - 21:00 UTC
This incident affected: QwickCards.com.