Partial Outage - Interface
Incident Report for QwickCards
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 21:08 UTC
Update
Operational
Posted Apr 25, 2022 - 21:07 UTC
Investigating
Qwickcards.com is experiencing a partial outage. QwickCards is not working if you are using an interface. We will notify you when it has been fixed.
Posted Apr 25, 2022 - 17:56 UTC
This incident affected: QwickCards.com.