Service Interruption
Incident Report for QwickCards
Resolved
Power is restored and service is operational.
Posted Jan 11, 2023 - 22:40 UTC
Update
We are continuing to investigate this issue.
Posted Jan 11, 2023 - 22:40 UTC
Investigating
QwickCards.com is offline due to power outages. We will report back as soon a full service has been restored.
Posted Jan 11, 2023 - 19:09 UTC
This incident affected: QwickCards.com and QwickCards.com Job Server.